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What’s New In SA

• SA Toolkit Bar
The SA Toolkit bar provides a set of new tabs for quick access to The SA Toolkit bar provides a set of new tabs for quick access to 
functionality related to GD&T, part inspection, analysis, and 
reporting.

• GD&T.
What was formerly known as the GD&T bar has been brought on as What was formerly known as the GD&T bar has been brought on as 
a tab in the Toolkit bar.

• Relationships. 
The relationships tab enables one-click definition of features 
(defined by CAD (defined by CAD 
or using primitive geometry) primed for easy inspection using 
geometry relationships, with or without projection planes. Other 
relationships can be easily defined as well.

• Inspection. • Inspection. 
The inspection tab presents all trappable features from all 
collections—relationships, 
datums, and feature checks—in a single list. This allows you to easily 
advance through an inspection routine, trapping measurements for 
each feature, and instantly providing inspection results against each feature, and instantly providing inspection results against 
nominal data.

• Analysis.
Some of the more commonly-used analysis tools, such as the frame 
wizard and geometry fitting, are presented together in the analysis wizard and geometry fitting, are presented together in the analysis 
tab.
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• Reporting.• Reporting.
Functionality for creating reports, making dimensions, and 
creating/annotating 
callout views is gathered together in the reporting tab.

To display the Toolkit bar, right-click on the menu/toolbar/status bar area 
of the SA interface and select Toolkit.of the SA interface and select Toolkit.

Reporting Enhancements

• Headers/Footers & Templates

You can now define custom headers and footers for your own reports, 
including elements that update automatically (such as SA version, page 
number, and date). Headers and footers can contain anything a report number, and date). Headers and footers can contain anything a report 
body can contain: images, text, tables, and fields—simply drag elements 
as you would anywhere else on the report (see following image). While in 
the header/footer edit mode (accessible by double-clicking a header 
/footer, right-clicking a header/footer or by selecting Edit>Modify 
Header/Footer from the report window), you can resize the header Header/Footer from the report window), you can resize the header 
/footer by dragging its divider.

When you’re happy with your header and footer, exit the mode by 
selecting Edit>Modify Header/Footer again. This will lock the header and 
footer in place, although dynamic fields will update as usual. If you’d like 
to set the report as a template for future reports, right-click the SA report to set the report as a template for future reports, right-click the SA report 
in the tree and choose Default Template, or select File>Make Default 
Template from the report window. This can also be done through the 
User Options>Reporting tab. Any additional reports created in the file will 
match the template’s format.

To use the template in other files, you can import the SA file containing 
the report template into the other file.

•Keyboard Zooming•Keyboard Zooming

You can now zoom in and out in the report window using the + and -
keys. Zooming to 100% can be accomplished by pressing Enter.
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•Jump to Page

Quickly jump to any page in your report by pressing Ctrl-G (for Go) while 
in the report window.

• Image Border Control

Disable the display of borders around images from the report’s page Disable the display of borders around images from the report’s page 
settings options by clearing the Draw Images with Border checkbox.

• Page Settings for Report Templates• Page Settings for Report Templates

Page settings for report templates can now be controlled from the SA 
Report Template properties dialog. In that dialog, click on the Page 
Settings button to define the parameters for the final generated report.

• Assigned Reporting Frames

Individual objects can now be reported/displayed with respect to a 
specified coordinate frame—not necessarily the active frame. This allows 
you to have any coordinate frame active while always viewing a given you to have any coordinate frame active while always viewing a given 
object relative to its assigned coordinate frame.

To assign a specific reporting frame to an object, right-click the object 
and select Reporting Frame from the context menu.

Be aware that the reporting frame applies to reported values in the Be aware that the reporting frame applies to reported values in the 
report bar and reports only. For example, when double-clicking a point 
to view its coordinates, you will always see the coordinates relative to 
the active coordinate frame, regardless of the point group’s assigned 
reporting frame.
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• Clipping Planes

Support for full clipping planes has been added to the graphical view. This 
is a great option when you want to display a cutaway or cross-section of 
your data. You can define as many clipping planes as you’d like, and any 
of them can be active at any one time.of them can be active at any one time.

Any number of objects can define the position and orientation of clipping 

cubes, and each clipping cube can have up to six clipping planes. 

You can interactively drag and resize the clipping box to reposition the You can interactively drag and resize the clipping box to reposition the 
clipping planes.

For more information on View Clipping, see “View Clipping” on page 71.
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• GD&T: Fit to Points

A new creation option has been added to GD&T: SA Objects (fit 
to points). This enables you to create a form or orientation GD&T 
check directly from measurements, instead of creating nominal 
geometry first.

For example, to perform a circularity check on a set of measured For example, to perform a circularity check on a set of measured 
points, ensure that SA Objects (fit to points) is selected. Click the 
circularity button, select the measurements, then press Enter. 
The circularity results will be calculated immediately.

• Geometry Relationship Features

Several changes have been made to geometry relationships that Several changes have been made to geometry relationships that 
improve flexibility and functionality.

• Projection planes can now be defined for line, circle, 
and ellipse geometry relationships. 

This can be accomplished by either choosing the Project to Plane 
option in the relationship’s properties (above), or clicking the option in the relationship’s properties (above), or clicking the 
Projection Plane: Active checkbox in the Relationships tab of the 
SA Toolkit bar. In the latter case, the selected projection plane 
will remain active and apply to all following geometry 
relationships until the checkbox is cleared.
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• Geometry Relationships can now be switched 
between “fit only” and “fit and compare” types. between “fit only” and “fit and compare” types. 

By selecting the Compare to Nominal option (above), you can 
select nominal geometry to use for “fit and compare” 
relationships. If you simply want a basic geometry fit 
relationship, simply clear the checkbox.relationship, simply clear the checkbox.

• Nominal Geometry can be created from the 
relationship properties. 

If you have an existing “fit only” relationship, you can create 

• New menu item for fit and compare relationships.

If you have an existing “fit only” relationship, you can create 
nominal geometry for it and convert it to a “fit and compare” 
relationship by clicking the Create Nominal button in the 
relationship’s properties.

•A new menu item (Relationships>Geometry Comparison>Select 
Nominal Geometries) has been added, along with a button on the 
SA Toolkit’s new Relationships toolbar, that creates fit and 
compare relationships from SA objects such as planes and circles. 
This is similar to Relationships>Geometry Comparison>Fit and This is similar to Relationships>Geometry Comparison>Fit and 
Compare to Nominal, but doesn’t prompt for existing measured 
points.

• New option to clear point associations.

Point associations for any type of relationship can now be cleared Point associations for any type of relationship can now be cleared 
by selecting the new Clear Point Associations context menu item. 
This is available for both individual relationships and the parent 
relationship category in the tree. (From the SA Toolkit’s 
Relationships tab, you can also choose to delete the cleared 
points from the file).points from the file).
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New MP Commands
For details on these new MP commands, see the MP Command 
Reference.

• Reporting Operations>Report Bar>Add Custom Tables to Report 
Bar.  Adds one or more custom tables as tabs in the Report 

• Reporting Operations>Custom Report Tables>Set Custom Table 
Cell Font. Sets the font for a specific cell in a custom table.

•Reporting Operations>Custom Report Tables>Delete Custom 
Table. Deletes a custom table from the tree.

• Reporting Operations>Set Scale for Picture. Assigns a scale value 
to a picture to control its size when added to a report.to a picture to control its size when added to a report.

• Reporting Operations>Append Items to SA Report. Sequentially 
adds one or more items to an SA report.

• Reporting Operations>Make New SA Report. Creates a new, 
empty SA report (using a defined template, if one exists).

• Reporting Operations>Output SA Report to PDF. Exports an SA • Reporting Operations>Output SA Report to PDF. Exports an SA 
report to a PDF file.

• Utility Operations>Copy Directory. Copies a directory from one 
location on the file system to another, optionally replacing the 
destination folder’s contents.destination folder’s contents.

• Utility Operations>Set Notification Cancel Override. When 
enabled, the Cancel button and “X” in the corner of the window are 
not displayed in dialogs resulting from any “notification” command not displayed in dialogs resulting from any “notification” command 
(such as Notify User String).

• Utility Operations>Set Automatic Backup State. Enables or 
disables full file and measurement automatic backups.
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• Utility Operations>Move Robot/Machine through Path. 
Commands a robot/machine to pass through a sequential set of Commands a robot/machine to pass through a sequential set of 
coordinate frames, optionally interpolating between those 
frames as linear segments or as a smooth spline.

• View Control>Set View Clipping Plane. Creates a clipping plane 
on a specified object.on a specified object.

•Construction Operations>Frames>Construct Frames – Average 
of Other Object Frames. Creates a frame with the average 
position and orientation of the supplied frames.

•Construction Operations>Other MP Types>Decompose •Construction Operations>Other MP Types>Decompose 
Transform into Vectors (Origin and Axes). Converts a transform 
value into four vectors: one for the origin and one for each of the 
three axes defining the transform.

• Construction Operations>Other MP Types>Make a World • Construction Operations>Other MP Types>Make a World 
Transform Operator (from Transform and Scale). Converts a 
separately supplied transform and scale factor in to a single 
world transform operator.

• Process Flow Operations>Ask for User Decision Extended. 
Provide a question or prompt and a series of choices to appear in Provide a question or prompt and a series of choices to appear in 
buttons. Clicking a button will jump to a specified step. Similar to 
“Ask for User Decision”, except allows many more than three 
potential answers.

• Analysis Operations>Query Frame to Frame. Queries the delta • Analysis Operations>Query Frame to Frame. Queries the delta 
between two coordinate frames.

•Analysis Operations>Query Point to Objects. Compares a point 
to one or more objects and returns the resulting deviation.

• Analysis Operations>Remove i-th Object From Collection • Analysis Operations>Remove i-th Object From Collection 
Object Name Ref List. Removes the specified object from a 
collection object name reference list.
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• Analysis Operations>Remove i-th Point Name From Point 
Name Ref List. Removes the specified point from a point name Name Ref List. Removes the specified point from a point name 
reference list.

• Analysis Operations>Auto Filter Points/Groups/Clouds to 
Surface Faces. Filters a set of points, groups, and/or clouds to a 
series of provided surfaces. Equivalent to the Construct>...>Auto series of provided surfaces. Equivalent to the Construct>...>Auto 
Filter to Faces commands.

• Instrument Operations>Dock Instrument Interface. Docks or 
undocks an instrument interface to the SA user interface.

New MP Editor Features

• Recent Files. A list of recent files are now displayed in the MP • Recent Files. A list of recent files are now displayed in the MP 
Editor.

• Moving Blocks of Steps. An entire block of MP steps can now 
be moved up or down in the MP Editor. Select the steps you’d like 
to move, then click the up or down arrow to move the set of 
steps as a unit.steps as a unit.

New Features for SA Machine on request
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• Events
SpatialAnalyzer Webinar
21. August 2012 at 20 Uhr German time via Internet 

Our partner New River Kinematics /USA offers a SpatialAnalyzer 
Webinar free of charge!

In cooperation with Quality Digest  the new features ofIn cooperation with Quality Digest  the new features of
version SA 2012.07.09 will be presented and as well the new
functions.

For more information read here: 
http://www.kinematics.com/about/events.php

4. Advanced Training Course „Optical measuring for particular
cases in machine building“ at Geodetic Institut KIT , Karlsruhe 
02. October 2012 | Karlsruhe 

VMT  GmbH  is representing at the partner exposition

http://www.gik.kit.edu/omam2012.php

Projectdialog SpatialAnalyzer
The 4. German User Meeting of SpatialAnalyzer Software

08. – 09. November 2012 | Bruchsal | at VMT

More information you will get in short time on our webside:
http://ims.vmt-gmbh.de/events/

More Information:More Information:

Industrial Measurement department of VMT GmbH has got a new own
web side on which we will keep you informed about our products, 
services and news.

http://ims.vmt-gmbh.dehttp://ims.vmt-gmbh.de
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