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One of the very significant advantages of SpatialAnalyzer is that de-
velopment occurs at a brisk pace. New feature requests, bug fixes, and
changes are implemented quickly, giving you the opportunity to start
taking advantage of new or requested features in a very short time.

New SpatialAnalyzer Version:
SA 2013.08.02

. User Options [ = ]
Expanded File Import/Export Support
Display I Units I Analysis | Reporting |
. . Hidden-Point Bar Databs i i
The commandFile>Export>Other>Surface Wireframe e Fort B Dtebose | Mt Gyt Senety ], utonctn
0 - 2 Point, AtoB = 10.0000 AtoC =

Add 2 Poirt Bar
Curve File(s) (.crv) has been added. This command

1 - Fdure, () Reference Point=

| Add N Poirt Frame

writes a wireframe representation of selected surfa- fidden ot e . W
Fixture Location Points

ces to a text file containing 6 comma-separated values T — - v Z o

defining two endpoints of a line in Cartesian coordina-

tes: Ax, Ay, Az, Bx, By, Bz. The command File>Import>-

Custom Formats>Leica ADF (.adf) has been added to Fit Tolerance: 10

. . . Fisture Hidden Measurement Paoint
support the import of Leica ADF files. ndainad
. . T ting Olff set:

Direct CAD Access import support has been added for seenethEE

Planar 0.0 Radial 00

the following file formats:

Automatic Hidden-Paint Camputation
By using a special haming corvention, it is possible to have Spatialanalyzer
ACIS v23 (.SAT, .SAB)

autamatically compute the hidden-points a3 the data from the fisture is taken. To
do this. follows this naming convention.

Shoot reference point 0 named: mypoint$0_0
AUtOd eSk | nve ntO r 2 O 1 4 Shoot reference point 1 named: mypoint$0_1
Shoot reference point 2 named: mypoint$0_2
CAT | A V 576 R 2 01 3 (R 2 3) "mypoint" will automatically be computed and added to the database.
j Syntaw: <paint names $<hidden point bar index>_<reterence paint index> L
Adobe 3D PDF (.PRC) EJ
Rhinoceros (.3DM)

Siemens NX 8.5 To use this new feature, first measure all points on the

fixture and construct the hidden point manually. Then,
Hidden Point Fixtures

in the Hidden Point-Bar Database tab, click to add an

In the User Options>Hidden Point-Bar Database tab, N Point frame. Add the points defining the fixture’s

you can now define a hidden point fixture. This allows orientation, then choose to pick the hidden point, and

you to use three or more points to define another point enter offsets for the hidden point if desired.

on a fixture. Also, hidden points now support target off-

sets for the computed point.

VIMT
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Remove Measurements By Instrument Grid By Distance

The command Analysis>Measurement Simulations> In addition to the existing command to lay out points

Remove Measurements By Instrument will remove on a grid based on a count (which has been renamed

all measurements associated with a specific instru- to Construct>Point(s)>Layout>Grid by Count), a

ment, leaving non-measured points behind. new command has been added to lay points out on a

grid based on a spacing (Construct>Point(s)>

GD&T Actual Features & Solved Points Layout>Grid by Distance).

The GD&T Options dialog has two new options: Create This command maintains the specified spacing, laying

Actual Features and Create Solved Points. off points inside the specified boundary.

GD&T Options (Maka a Grid of Points g‘

. . . The grid will be created in the =Y plane of the working frame.
[T Use High Points for Feature Alignment

# s
[if ch_ecked, 3 hi_gh points whic_h also enclose the center of Min: | Max 1000 Distance: 10.0000
aravity of the points are uged; if unchecked, best-fit geometry
iz uzed [least squares])

Y fais
Distance Between Checks Use

Min: 0.0 Max 000 Distance: 2.0000
@ Centraoid ) Min/May Z tiis
Check Pre-Eval ¥alidator b b Brieres e
@ Nohe (C) ASME (1994) (D) 150 (1983) Destination
() ASME [2009) () IS0 [2004) Collection Name

[If an ASME or IS0 option is selected, additional walidation iz
done before check eval according to the selection and this is
alzo indicated in the reports.]

Group Mame: PaintGrid Pairt prefis: P

[The chaice of None ASMEASO does not affect the numeric L )

results from the GDET evaluation. |t only controls the

walidation done before evaluation to determing if the check

can be evaluated) XML Import
Create Actual Features The XML import and export format has been published
Create Solved Points

for the benefit of all users. For more information, refer to

) o)

“Importing XML Files” in the chapter “Working With Files”.
Create Actual Features. Creates actual measured

geometric features for GD&T checks. For instance, Reporting Improvements

if performing a flatness check, the plane repre- New Tag

senting the orientation of the plane used for the Anew system tag has been added, <<Filename Short>>,

flatness check is created. This allows you to query which lists the current filename without the full path.

your measured points to this plane to determine Borderless Tables

high and low points, for instance. Borderless tables can now be created in reports by

Create Solved Points. This creates the center right-clicking a cell and selecting Cell Options>Disa-

points used for true position analysis when deter- ble All Cell Borders. Select Cell Options>Enable All

mining if a feature is out of tolerance. Cell Borders to re-enable them.
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Fields

A new ComboBox widget is now available within re-
ports. Combo boxes allow you to present a drop down
list to a user in a report. The list items may be popula-
ted from report tags or static text. Simply right-click in

the field, select Cell Options>Make ComboBox.

Measurement Date- |3/2/2013

Measurement Location: g

Technician®

(Bldg. 77)
& Test (Bldg. 992)

Point Name

L x | ¥ | 2
0 3.8085| 86.3128| -0.4853
| 148.7137| 61.7509 -0.9637

Arrowhead Ends

Line arrowheads can now be added to just the start,

just the end, or both ends of a line.

Line Properties

S

Line Thickness: Medium? .
Style: Dashed
Armowhead:

Mone
_ End -
- ??ngi

Callout Styling

Individual callouts can now have their own leader/
border thickness/color and fonts. To modify an indivi-

dual callout’s settings, right-click the callout and select

Callout Styling.

1070
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Text Properties

The properties of a text block now contain controls for

font, background color, text color, border color, and

thickness:

Report Text Properties
Text

Background

sl

Teut Col

Background Color: _I
|gnare Background Color [Transparent]

Border
[7] Draw Border Around Test

Border Thickness: 1

Based on the above measurements, it appears
az though the foundation has sunk 0.023" from
the reference elevation in the southeast comer.

I

Cancel

SpatialAnalyzer Directories
The User Options>Machine Configuration tab now
allows you to select specific directories for each of the
standard SA directories, avoiding the need to edit the

registry to make such changes.

User Options ==
Display Units Analysis Reporting
Fdn-Poit BarDetaase_|  MoctineCorter

SpatialAnalyzer Directories
Data => C\Analyzer Data’.
Reports =» C\Analyzer Data"Reports'.
Templates => C:\Analyzer Data\Templates™
Persistence => C:\Analyzer Data'\Persistence™

Backup => C:\Analyzer Datz"\Backup'
License => C:\Analyzer Datz\License'

Select Root Directory to contain "Analyzer Data” and its subdirectories

RF‘ick new Directory for Selected Entry ]
SA Startup Options

Callout Snapping

Callouts with leader lines can now be constrained
along 45 degree angle increments. Simply hold down
the Shift key while dragging a callout with a leader line

to snap the callout and its leader line.
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Feature Inspection Auto Filter Cloud Organization

New Interface: OmniTrak 2

The GD&T>Feature Inspection Auto Filter command
has a new Create Cloud for each Datum/Check
option which will create a separate point cloud for each
datum or feature check. Keep in mind that this may
create multiple copies of a given cloud point, since one

point may be associated with multiple datums or

A new interface has been added for the APl OmniTrak 2

laser tracker.

feature checks.

Inspection Auto Filter - Settings

Face Offsets

Surface Offset Inches Edge Offset 0.1 Inches

b p
Surface OffsetDirection @ Both () Positive only (7 Negative only

Output Limits

|| Enforce Max Pts per Face in Output

Cloud Thinning Options... %ﬂeah& Cloud for each Datum/Check Cancel

New Interface: APl Axxis 7-100 7-DOF Probe Arm

A new interface has been added for the APl Axxis 7-100
7-DOF probe arm. This arm runs under the API Baces
interface, similar to the 6-100 arm. It supports the new

style 7-100 arms with the probe only (no scanner)
attached.

New Interface: Leica AT4xx

This interface has been added to support the Leica
AT402. The AT4xx designation is for support of future
models. Note that the AT401 can be run via this in-
terface, but the initial AT401 interface and instrument

model in SA are preserved for continuity.

This interface uses the API Device Interface, and has

as of yet been untested with hardware.

New Interface: Assembly Guidance Laser Guide

Projector

A new interface has been added for the Assembly Gui-

dance Laser Guide projector.

BE

This interface supports creating calibration (registra-
tion) files from SA. Simply select Instrument>Laser
Projector>Alignment. You will be prompted to select
the projector and the group of points you will use to
align the projector. In the interface, the Ul will be dis-
played to guide you through driving the projector to
each point in sequence with the mouse. Once you have
driven to all the points, the projector will register and
a file with the registration targets will be created. You
may use this file to register the projector with a single
click after the one-time manual drive, so long as the

projector is not moved.
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This interface supports projections from SA or from
pre-created files. You are able to project objects
from SA by selecting Instrument>Laser Projector>
Project Objects. The selected object will be pro-
jected and a file will be created using the name of
the first object. You have the capability to set the
interface to add objects to an existing projection file,
or to create a new file with each new projection. This
way, you may create your own database of projecti-
on files simply by writing them to a common folder
on your hard drive.

Once you have created a projection database, you can
use the Previous, Current, and Next buttons in the in-
terface to run through a given folder of projection files.
You must install LASERGUIDESDK_3_03_11.exe (or
later) before running the interface. This may be down-
loaded from the NRK FTP site: ftp://ftp.kinematics.
com/pub/SA/Install/Driver%20Downloads/
AssemblyGuidance%20LaserProjector/.

This FTP location also has batch files which need to be

executed to register the projector DLL in the SA install.

DOWNLOAD THE LATEST SpatialAnalyzer VERSION

Please note: You download the actual full version of SpatialAnalyzer, but you can use

only the full functionality if you have an actual software license key. In other cases

you can only work with the SA Viewer.

MP Automation

Indentation in the MP editor can now be controlled
using Tab and Shift+Tab. Select one or more lines,
then press these keystrokes to add or remove inden-

tation, respectively.

Support and Training

VMT is still your qualified partner for sales, training and
support of SpatialAnalyzer Software in German-spea-
king countries.

A reliable and efficient partnership exists between
VMT and NRK since nearly 10 years. Our companies
organize and presents commonly several events and
fairs, like the CONTROL in Stuttgart. VMT, as success-
ful partner in Europe, provides since several years a
working place for a NRK application engineer. After
Scott Sandwith has returned back to USA last year we
are happy to introduce Zach Rogers as his follower. If
you didn’t get to know him, you have a chance at our
next SA user meeting, the “Projektdialog SA 2013” in

November at Nordenham.

Click here to download the latest SpatialAnalyzer Version...

VMT GmbH | Industrial Measurement| StegwiesenstraBe 24 | 76646 Bruchsal | Germany
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